Zabbix Acknowledge no longer working

I have run into an issue and am hoping someone here may know how to help me with the solution.
I am running Grafana version 5.3.4 (69630b9) and have the Zabbix (v3.9.1) plugin installed. everything was working as expected when I was running Zabbix version 3.4, but when i upgraded it to the latest version (4.0), the acknowledge function in the Grafana Zabbix plugin stopped working. I have used the green “update” button in the Grafana plugin section to make sure the plugin is up-to-date, but have not been able to resolve the issue.
I know that with the Zabbix server upgrade to version 4.0, it made some changes to the Zabbix API that are likely the cause if the Grafana Zabbix plugin error I am seeing.
I am looking at the GitHub page for the Zabbix plugin and am seeing that there is a fix for the issue


but for whatever reason, I cant seem to get the plugin to update. I have tried manually making the changes, but that quickly proved not to be an option. I even tried installing from github directly, but was unable to figure out exactly how to make that work either.

Any help any of you can provide would be appreciated.

Thank you,
Carl Slaughter
Network Systems Engineer
IBM Cloud (SoftLayer)
Managed Services
Mon-Fri 9a-5p CDT