Yet another problem with alerting returning no data for elastic


When I first added the alert for elastic in version 5.x everything worked as expected so i didn’t recheck it after upgrading to 6.2.0. Turned out that now alerts aren’t firing and testing rule returns no data. I tried googling it and none of the cases i found helped, alas. I tried playing around with min doc count, size, ordering, alerting periods – nothing helped.

My current query setup:

Current alerting rule:

Could you please help me restoring the alerts?

Just to make it clear, the returned data for the query is correct and graphs are drawn correctly. It’s only the alerting that is wrong.

Have you changed version property in datasource configuration to 6.0+? Since you’re using auto as interval for the date histogram and the range is in total 10m you’ll get a very low interval - make sure that you’ve configured min interval property in datasource configuration to the rate of which you write to elasticsearch, for example 10s.

@mefraimsson Thank you very much for your prompt reply!
Regarding the versions, the elastic server version hasn’t changed since the alerting used to work. The version is 6.7.2 and it is set in grafana as version 6+. Only grafana was upgraded (stable helm chart installation).
As for the interval, the index is being written to almost every second, but for a single timeseries datapoints are written each two minutes. Given this, what would you recommend setting for datasource and query min interval? Date histogram interval? I’d be happy to follow any recommendation you might have. Thank you!

I still need help with this issue…