Wrong (old) version installed using apt

Hi all - I have been bashing my head against this all afternoon so putting out a shout for help.
The other week I sucessfully installed Grafana Server on a Raspberry Pi 2 and have had it test since then quite happily, but now I want to re-deploy it to the live project server on a Pi 3. As far as I recall I just followed the instructions on the main documentation page.

Today I have tried the same on the Pi 3 (they are both runing the latest stretch release) although it installs properly the login page looks all wrong (the logo is all different) and the version info underneath says “Grafana version: master, commit: NA, build date: 1970-01-01 01:00:00” whereas y original install is version 4.63.

I have tried apt-get purge and auto remove and finally tried again using the bintray distribution pointed to in postsI found about using raspberry pi. But evertime I get this old looking version.

What have I done wrong and how can I clean up my project server to put a proper version in place.

thanks in desperation


As usual a bit of time away from the keyboard and it became obvious. I had the correct entry in my sources.list file EXCEPT it still pointed at jessie not stretch!

Version 5.0 now up and running :slight_smile: