Unsupported data format error when performing collection through zabbix data source

Problem: After updating grafana version to 8.2.6 , some metrics were no longer collected from my zabbix data source, the following error is displayed when viewing the template:

image

All metrics that have more than one item as an answer are not being displayed, such as amount of disk, consumption of disks, amount of network interface.

Any references on how to update the regular expressions of the zabbix datasource from the previous version of grafana to 8.2.6?

2 Likes

Hello ,
I have the same error I m using Zabbix 6.0 and grafana v8.2.5.
Any update please .

Bonjour, j’ai un problème similaire je rencontre une erreur quand j’utilises Zabbix 6.0.2 et grafana 8.4.4

Hello! I have the same problem. Is there a way to fix this?

Do you solve this problem?

I tried using this dashboard:

If you guys are using the same, I have same issues trying to solve it.

Is there somehow a way to contact/ping maintainer to take a look and push fixed version in case they did?

Eu tive esse problema.
Basta trocar o tipo da Variável de Application, para ApplicationTag.

I went into each panel and changed the Item Tag from APPLICATION: CPU (because it’s no longer used) to component:cpu.

Hi all,

The Grafana plugin for Zabbix is basically a community-based plugin (i.e. not maintained by us).

The best approach here is to inform the Zabbix Engineers by reporting this as an issue on their GitHub page.

Good afternoon, let me know if you were able to fix this error, if so tell me how?