Unexpected EOF Error with Wiremock

I’m trying to call a simple Wiremock GET call and I’m getting a strange EOF error.

WARN[0001] Request Failed error=“Get http://localhost:15345/__admin/mappings: EOF”

This is the extent of the error message. I don’t get any other details even with --http-debug=“full” enabled.

I can make the same call using curl without any problems.
Calling this gives me a valid response.

Hi @tromney,
what is the output of k6 version, are you running this inside docker or some other container, if so can you try using curl from inside the container.

Have you tried wireshark to see what happens on the network layer ?

k6 version gives me
k6 v0.26.1 (dev build, go1.13.8, darwin/amd64)

I’m not running k6 inside docker. I’m running both k6 and curl from a local terminal.
The service that I’m trying to hit is running in docker though.

I’ll try wireshark and see what I get.

Looks like when my request contains a non standard port number I get this error.
If I run the service on a standard port I get the error.

Hi tromney,

I also was facing the same issue and it was something wrong with SSL because I was getting that issue working with HTTPS. So, I deleted my container and I ran it again but this time I opened a port for HTTP, something like this:

docker run --name cali-server -p 15345:10443 -p 8282:8080 -d 724fc23299d7

where 724fc23299d7 is the imageId.

After that, I ran again K6 but hitting 8282 port and it is working. I kept 15345 because postman and other callers are working with it.