K6 socket loadtest

  • k6 version: v0.32.0
  • socket server version: v2.2.0

when I ran example loadtest from k6 doc, I keep seeing the error like the following.

ERRO[0003] GoError: unexpected EOF
at go.k6.io/k6/js/common.Bind.func1 (native)
at file:///C:/Users/yaochia/Documents/Training/haps.io/internal/load_tests/test.socket.js:18:41(15)

What does it mean and what have I missed?

This probably means that the remote server closed the connection or something like that. Can you share some more details about your k6 test and WS server, for example which example from the docs are you trying? I just tried the one from here and it worked :man_shrugging: I can’t help you without some more details, sorry.

I am using the exact same example as you mentioned.
for the socket server, I am using this https://www.npmjs.com/package/socket.io one with v2.2.2.

I did not get any socket event when I launched the test from my socket server side.

or could you direct me to your WS server? the detail of the WS server.

I suspect it is a socket compatibility issue. Client Installation | Socket.IO

websockets are not the same thing as socket.io, k6 doesn’t support socket.io natively, though as you can see from the issue, some people have made it work: Add support for socket.io · Issue #1306 · grafana/k6 · GitHub

I am not familiar with plain websocket libraries for node.js, but here are some I could find on npm: websocket - npm, ws - npm :man_shrugging:

1 Like