Unable to add InfluxDB as a new data source

  • What Grafana version and what operating system are you using?
    grafana-9.1.6 and influxdb-1.8.10 on ClearOS7 (binary compatible with Centos7).

  • What are you trying to achieve?
    Set up the TIG stack as a complete newbe.

  • How are you trying to achieve it?
    Following various guides for Centos7
    Basic installation of Grafana, InfluxDB and Telegraf on CentOS 7 – PetersPlanet.nl
    and other link which I can provide but can’t post in my first post as a new user.

Using yum to install all components from the source repos so I mixed and matched from the various references…

  • What happened?

  • What did you expect to happen?
    When I added the InfludDB data source, I expected it to work when I hit “Save and test”

  • Can you copy/paste the configuration(s) that you are having problems with?
    Very basic database name, database user and database password.

  • Did you receive any errors in the Grafana UI or in related logs? If so, please tell us exactly what they were.
    In the UI: error connecting influxDB influxQL
    In the logs:

logger=tsdb.influxdb t=2022-09-23T20:29:57.674221625+01:00 level=warn msg="error performing influxdb healthcheck" err="error connecting influxDB influxQL"
logger=context traceID=00000000000000000000000000000000 userId=1 orgId=1 uname=admin t=2022-09-23T20:29:57.674450762+01:00 level=info msg="Request Completed" method=GET path=/api/datasources/3/health status=400 remote_addr=172.17.2.116 time_ms=6 duration=6.90728ms size=66 referer=http://sia2.howitts.co.uk:3000/datasources/edit/07EHJU74k traceID=00000000000000000000000000000000 handler=/api/datasources/:id/health
  • Did you follow any online instructions? If so, what is the URL?
    See above.

I then bumped into this thread which is for a slightly earlier version of Grafana 9.1.x, and I tried its suggestion of downgrading to grafana-9.0.8 and it worked immediately and the “Save and test” button worked.

Is there something different needed in 9.1.x or is it a known bug or does a bug need to be filed.

Looks like a duplicate of https://community.grafana.com/t/grafana-9-1-3-impossible-to-connect-a-datasource-from-influx-1-8-10/72348 which has not been answered either. I guess a bug report is needed.

[edit]
It looks like there is a bug report at https://github.com/grafana/grafana/issues/55707
[/edit]