The names are ugly and I want them gone

I’m struggling with a standard Bar gauge panel see image.
I tried :

  • setting Alias to none or empty or space , this causes the original field name to be displayed ;
  • setting Override > Matcher > Filter by Field > Display name to none or space , same as previous.

Anything else I could to try ?
Shouldn’t the field names behave same as the Panel Title ?
What am I missing here ?

interesting – empty string is the same as not set… and leads to the default behavior (showing the name). Looks like we need a setting to not show title – perhaps we can reuse the new name settings in the stat panel