TestData plugin failed, build from source on windows

I Have built grafana from source on windows and I had the impression everything went ok. However when I enable the TestData app plugin and open one of the imported dashboards the following error pops up:

Grafana TestData plugin failed
Error: Fetch error: 404 Not Found Instatioating http://localhost:3000/public/app/plugins/app/testdata/\datasource/module Loading app/plugins/app/testdata/\datasource/module

I built from source on two different windows machine with the exact same result. I also tried installing some plugins/datasources (pie chart, simplejson) through the cli and this seems to work just fine. I suspect the failing testdata plugin has something to do with the slash-backslash shown in the error message.

Any idea what might be going on? If you think this is a bug I’m happy to provide more details.

Thanks! Best regards, Remco

Strange, maybe windows related bug. Can you please open a bug report for this on our main github repo?

Sure! thanks for the reply

@remcopoelstra I am trying to build Grafana from source on windows but i have encountered some problems, and as i can see you have already builded Grafana. So would you mind having a look at my topic (Building Grafana from source)?

Any help would be appreciated! Thank you in advance!