Telegram notification was working, edited the template and now I always get "Failed Error 400"

I was using Telegram for my notifications, it was working untill I changed something in the default template. I don’t remember what, because I’ve deleted it and started as news, I also created a new Chat in Telegram with a new bot, and re-done everything, but every time I test it I get the:

Failed to send test alert.: Webhook response status 400 Bad Request

Grafana server is hosted on my raspberryPI and is the v8.5.5, everything is working as expected, and if I try to CURL to my bot from the Grafana server, also it works

root@Grafana:~# curl -X POST


so I don’t know what could be the trouble, maybe something related to a Grafana cache of DNS or similar issue?

How can I flush the cache or delete it?


welcome to the :grafana: forum, @giuliomagnifico

Can you confirm: are you using the new Unified Alerting platform or the legacy platform?

try increasing the verbosity of the Grafana server logs to debug and note any errors. For printing to console, set the console logs to debug as well.

1 Like

Hi Matt and thanks for the reply. Yes I’m using the latest platform for the alerts.

But now I solved, simply by using Pushover instead of Telegram. I prefer it because I can also customize the sounds for Firing or Resolved notifications.
I have no idea what was happening with Telegram but I’m pretty sure something related to dns or network (because I’m using a recursive DNS) cache.

I only have to understand how to not include the queries in the alerts, in order to have a more readable format. Now I got this and it’s too verbose (I’ve already tried to edit the name of the queries but it remains verbose)

Anyway maybe it’s a bit off topic, I’ll open a new thread for this.

1 Like