Table data does not match time series plot

  • What Grafana version and what operating system are you using? Grafana 9.0.7 on a windows server 2019

  • What are you trying to achieve? When comparing the table data in the table view and to what the time serie is plotting, the time serie has added 2 seconds to every data point and interpolated a new Y-axis value.

I’m querying a postgre 12 server and the query looks like this:
timedate AS “time”,
FROM steril_tt_01

Here is 3 screenshots of what is happening:

As you can see in the pictures: the table data at 09:44:55 should be 6, but in the plotted time series graph the time is 09:44:57 and the value is now 10

So my question is this a bug or have anyone else seen the same issues and solved it? Have I done something incorrect in my procedure?

welcome to the :grafana: forum, @peter1233

those timestamps don’t match…

is your timestamp UTC?

I know, there is a difference of 2 seconds between table and graph view.

But i solved it, i added the macro fimefilter and it resolved the issue