Snapshot option is missing

I wanted to share a panel via raintank. The snapshot option is completely missing from my Grafana 7.5.6. I can’t find any references to this problem anywhere. Any suggestions?

EDIT: to be explicit: the menu shows as “Share Panel Link Embed” whereas I believe it should be “Share Panel Link Snapshot Embed”.

Hi @cville,

Can you share a screenshot? I just spun up a 7.5.6 instance and I can’t see anything missing.

What about on the Grafana sandbox running Grafana 8-beta rn?

Thanks for replying; here’s the requested screenshot:

EDIT: I tried the 8.0 sandbox, using the memory/CPU panel as an example: same behavior.

Are these not the snapshot options you are seeking?

Absolutely. But as you can see from my screenshot, that option is missing.

Does that remain true for every browser & operating system combination
available to you?

(I have no idea how many machines / boot options / browsers you have, so I
thought I’d leave the question openly generous.)

PS: Just out of interest, what permissions does the user you are logged in to
Grafana as have? Viewer / Editor / Admin?

Antony.

Before I say something about platforms, I want you to know that the snapshot function, until recently, always worked for me. Since I don’t need it that often, I don’t know which version update introduced this problem. I can also tell you that my Grafana instance does not require a password.

Having said that, the problem occurs with all browser/platform combinations I’ve tried:

  • Windows 10 with Chrome & Firefox

  • iPadOS with FireFox

It seems unlikely that the OS/browser is causing this problem.

DId you manage to resolve this issue cville? Asking because I’m seeing exactly this issue as well running version 7.5.3.

edit: reverting back to 7.4.1 resolved this issue - Share dialog contains the Snapshot tab. has this issue been resolved since 7.5.3? I reviewed the change logs since 7.5.3 and did not see anything obvious re: snapshots.

No response from Grafana and no, I never got it to work on 7.5.3. I installed 8.0 and this has the same behavior on my existing dashboards. However, snapshots are available on newly created time-series panels.

curious to know if this issue persists for others in grafana 8+

I still run into this issue in v8.2.1. However I don’t see anything in these forums or via a Google search so I can’t rule out my own environment.

If i switch to v7.4.1 in my setup, Snapshot export works. Switching back to v8.2.1 in the same setup and the Snapshot button disappears when the Share button is clicked on a dashboard.

Frustrating.

I have the same Problem for dashboard snapshots.
After updating to Grafana 8.1.5 the tab is missing


I did not find any option to switch in off in general in documentation

Is there still no idea how to switch on snapshots again?

This topic was automatically closed after 365 days. New replies are no longer allowed.