Settings do not change

I want to set
allow_embedding = true
Then I restart my server with
sudo reboot
Then i check the settings in grafana, but they did not change. Can Somebody help me ?

Sure thing, can you reply to these three questions?

  1. What OS are you running? (Ubuntu? MacOS? Debian? Fedora? Red Hat? FreeBSD? Windows? [probably not since you mentioned sudo reboot])
  2. How did you install Grafana? (Package? Docker? Did you follow a specific guide?)
  3. Which configuration file are you editing?

@emiltullstedt

  1. Raspbian Buster Lite
  2. https://simonhearne.com/2020/pi-influx-grafana
  3. /etc/grafana/grafana.ini

Ok, that seems to be the correct configuration file and the installation instruction seems correct.

Are you sure you’re editing allow_embedding under the [security] subsection?

By the way, if you want to just restart Grafana, you can do so by writing sudo systemctl restart grafana-server, you don’t have to restart the server itself :slight_smile:

Yes
/etc/grafana/grafana.ini

systemctl restart grafana-server

Grafana

Ah, thanks for the screenshots.

You’ll want to remove the ; at the very start of the line. It tells the configuration to ignore that line. I’ve seen this happen before, we should really make that much clearer.

1 Like

Thanks that worked. Now I have the problem that if I want to embed a panel. Then the login page appears on the website and not the panel.

I’m not confident in this, because I’ve never tried this, but you might have to set the cookie-samesite option to none for iframes to work. See the security.cookie-samesite documentation and this post on SameSite Cookie Recipes for some background.

I logged in one time. Now it runs, even if I refresh the page

Nice! :raised_hands:

But if load the website on a other device, I have to log in again…

Yes. If you connect from another device, how would Grafana know it is the
same “you” until you’ve given it your username & password?

Antony.

Is it possible that i don’t have to log in and everyone can see the panel?

Yes, you can allow anonymous authentication, see

1 Like

I’m not able to see the contents of grafana.ini. Using vi etc/grafana/grafana.ini command on Ubuntu. Could you pls help?

  1. Please give more information - instead of just “I’m not able to…” tell us
    what happens when you try.

  2. It could be something as simple as missing a leading / on the pathname.
    Depending on where you were when you ran that vi command, it will be looking
    for ‘etc’ in the local directory, and that may not exist.

  3. Show us what the output of “ls -l /etc/grafana” is.

Thanks,

Antony.

Thanks for replying.
Actually I want to render my charts in html for that I need to set allow_embedding=true; but when I make these changes into the grafana.ini file it did not changed in the grafana console and also I’m getting an error. Attaching screenshots below for better understanding.
Thanks