Relative time $__interval is not working for 2d

Hello ,
Grafana version - 7.5.5
Loki version - 2.2.1

we are using max_over_time and count_over_time function for counting the logs over time period of an application.
We are using the Global time range filter $__interval variable and defined the max point as 1. With this configuration $__interval calculating as 1d for 2d range filter, it is working fine with 1d and 7d range but not working with 2d time range.

1 Like

Got the same issue with Grafana 7.5.6 and prometheus.
But it is actually Grafana setting the interval to 1d instead of 2d. even with Max data points
to 1.
I’ve similar problem while selecting 3, 4, 5 and 6 days… it does pick up only “1”.
Starting 7days, it does choose 7.
until 20d… when we use 21, it switches to 30d…

Counting is then not working at all along with time picking…