Problem with epoch timestamps to human readable date conversion

Grafana version : 4.6.0
Datasource : Zabbix (Plugin from
OS : Ubuntu 14.04

Hello! I’m still in the process of learning how to handle grafana properly and I’m at the point I need some help.

I’m pulling from Zabbix an epoch timestamp in seconds, which is easier to handle with triggers than string dates, in a Singlestat panel.

The problem is that I need grafana to show a human readable date, whatever the format is (need year, month, day, hour, minute and second).
I couldn’t do anything useful with “options/unit” because it gaves me a date from 1970.

I tried to find equivalent issues but found nothing close to this, or closed issued without useful informations. I tried to configure Zabbix so it knows it’s a “unixtime” unit but always returns it in an epoch timestamp format in Grafana. I also tried to look if I could work something with the functions in query mode but found nothing.

Am I missing something that could do the job? Should I open an issue to ask for a feature that could handle epoch timestmap in pretty format?

I couldn’t put the third screenshot of the Metrics tab because I’m new here, but here it is.

I have the same problem.
Managed to solve?


I found a workaround on a forum. I used a scale x1000 function on the metric and it worked using a time and date unit.


Worked for me either, thanks!

It works on v6.1.0

I have to say that it’s a weird feature.


Not working for me. v6.6.1 (21bf8b71bc)
When I put a timestamp in like 1581982319 it gives “1970-01-19 02:26:22” as those above noted. However multiplying times 1000 corrects the time, but the date disappears! How to I get it to show the date AND time?

Playing around a bit more, I see it DOES display the date if the timestamp is far enough away from the present. Very strange behavior.

Did you ever figure this out @wkoontz? I see the same thing, the date disappears. I am running 6.3.6.

1 Like