Plugin Missing after installing

Raspberry Pi Grafana 7.1.1
I tried to install a plugin. here’s how I installed it and the response. It does not show up in Grafana

pi@masterpi:~ $ sudo grafana-cli plugins install vonage-status-panel
installing vonage-status-panel @ 1.0.9
into: /var/lib/grafana/plugins

pi@masterpi:~ $ grafana-cli plugins ls
installed plugins:
grafana-clock-panel @ 1.1.1
grafana-piechart-panel @ 1.5.0
vonage-status-panel @ 1.0.9

:heavy_check_mark: Installed vonage-status-panel successfully

I restarted and even rebooted when the restart didn’t resolve the problem?

Hi @djferrey - is it only the Vonage plugin that isn’t displaying? If so, unfortunately there hasn’t been much development on that community-built plugin in 2 years and many other Grafana 7 users appear to be having issues with it. The developers from the Vonage team mentioned back in April they’re a bit bandwidth constrained so it’s not likely to be updated for v7 compatibility any time soon :

You might want to check out the Grafana-built Stat panel as an alternative if you need a quick fix:

Thanks. I’ll take a look. That panel might help me figure out how to display metrics from multiple nodes. I like the panel but I can’t find it on your site?
Thanks again

Stat panel comes natively with Grafana 7 and you shouldn’t need to download it separately from the plugins page. After you add a new panel to your dashboard, you should see the panel edit menu on the right of your screen and there’s a drop down for Visualization options where you can select it:

Thanks. Here I’ll expose my level of knowledge with grafana.
I created dashboard, added the stat panel. Based on the doc
I assumed It would have “everything” there. I just need to add the prometheus data source.

Where am I going wrong, please