No login credentials shown

I installed Grafana and creatd some dashboards which I use in my IPSymcon home automation.
Today I want to login to Grafana to crata another dashboard but it is not possible to login because there are not login credentials requested when entering the login page. It is not a browser problem i tried it with Chrome, Edge and Firefox. The only thing I see is this:


  1. Restart grafana
  2. Check log file for errors
  3. Check dev tools console for errors

Hi @thomasw69,

So by default the admin login credentials are

username: admin
password: admin

Have you already tried it?

If that is not working then it might be that you may have forgotten your password. You can reset the admin password by following our Documentation:

Let us know if this helps.

hi @thomasw69

here is another suggestion, how do authenticate your login? there are some authentication methods and configurations that may cause loosing the login form

Perhaps I have expressed myself in a somewhat misleading way. I only get the above image. No login dialog appears in which I could enter any login data. Grafana is running on a Windows 10 system.

Hi @thomasw69,

I think we all might be making things a bit complicated. So here is a basic question.

Do you have access to the server (SSH) where Grafana is installed?

If Yes, then simply reset the admin password by following the documentation.

Once done, log in as admin and then you can reset any user password with that.

Let us know if this helps.

Did this help? I have the same problem.

Edit: I tried to reset the password. Still don’t get fields to input username and password only the Welcome to Grafana image. I have restarted the Grafana service and that have made no difference.

Edit (2): Found the solution. disable_login_form was set to true. Don’t know why I have not changed it. but I changed it to disable_login_form = false and now i get the input fields for username and password


Thank you for this solution but it came a little bit to late for me. I did a complete new install of Grafana.

My grafana runs about one or two weeks and then the same error occurs again.
It’s just maddening. I get the login dialog again when I set disable_login_form = false, but login still doesn’t work. It accepts the username and password I saved in the browser (so no wrong input) but I can’t edit anything. It is as if I am not logged in. If I uninstall Grafana completely, losing all dashboards of course, and I recreate them after reinstalling, then I can work again for about 2 weeks.
Working with such a system is not possible!!!

Hi @thomasw69,

What Grafana version you are using?

Does it also occur in your new fresh install (as I understood from your previous post, you did a fresh install)?