"no LDAP servers defined in config file" inspite of being defined yes

Grafana ldap connection
no LDAP servers defined in config file

I am completely new to ldap configuration, and only somewhat familiar with Grafana configuration.
Trying to connect the ldap we are using for the SUSE LES shell for the grafana ldap config.

I have set ldap=true and provided the ldap.toml file below, for which the grafana appliation user has access rights.

grafana log:
t=2021-01-18T08:09:33+0100 lvl=info msg=“LDAP enabled, reading config file” logger=ldap file=/etc/grafana/ldap.toml
t=2021-01-18T08:09:33+0100 lvl=eror msg=“Error while trying to authenticate user” logger=context userId=0 orgId=0 uname= error=“Failed to get LDAP config: LDAP enabled but no LDAP servers defined in config file” remote_addr=

I do not know where this remote address comes from.
The address given in the ldap.toml file works.

os shell:
→ cat /etc/grafana/ldap.toml
host = “”
port = 636
use_ssl = false
start_tls = true
ssl_skip_verify = true
bind_dn = “dc=section,dc=corp”
search_filter = “(cn=%s)”
search_base_dns = [“dc=section,dc=corp”]

-> curl -v telnet://
  • Rebuilt URL to: telnet://
  • Trying…
  • Connected to ( port 636 (#0)

This is based on the shell config at

→ cat /etc/ldap.conf
bind_policy soft
pam_lookup_policy yes
pam_password exop
nss_initgroups_ignoreusers root,ldap
nss_map_attribute uniqueMember member
nss_schema rfc2307bis
pam_filter objectClass=posixAccount
ldap_version 3
network_timeout 1
timelimit 1
bind_timelimit 1
timeout 1
base dc=section,dc=corp
uri ldaps://ldap-master ldaps://ldap-replica01 ldaps://ldap-replica02
tls_checkpeer yes
tls_cacertfile /etc/ssl/certs/corp/ca_cert_bundle

where the alias ldap-master translates to the ip above.
Also tried with that alias in ldap.toml, same result

Solved for this step: [[servers]] headline

This issue is solved by inserting the
headline in the ldap.toml file.