No errors in promtail logs, but unable to see logs in grafana cloud

Hi everyone, new user to grafana cloud. We are trying to migrate from cloudwatch to grafana, and use promtail to push data to grafana. To do this, I went to hosted logs section, created a token, copied the config from there, updated the log paths and ran promtail using docker. There are no errors, but I don’t see any logs in grafana.
I tried to follow the trouble shooting doc. I ran promtail using dry run and the logs from the log files are being printed in the console. I tried pushing logs to promtail from stdin (using cat test.log | promtail --stdin …), and there’s no errors when running that command either. I have no idea what we are doing wrong here, so any help is appreciated. Thanks!

Can you share your configuration, please?

If you are running promtail in a container but want to scrape logs from host, make sure the logs directories or files are mounted readonly into the promtail container.

Thanks for the response. Turns out loki just needed some time for the initial sync to happen. I have no idea why there was that much delay initially, but the problem sorted itself out without me doing anything.