Newly installed grafana v6.7.2 (423a25fc32) on ubuntu unauthorised to change default password

I have freshly installed grafana * v6.7.2 (423a25fc32) on ubuntu, on default first login when I try to change admin password it says error Unauthorised.

sudo cat /var/log/grafana/grafana.log

I checked the log and I noticed this:

t=2020-04-05T15:15:59+0100 lvl=info msg=“Successful Login” logger=http.server User=admin@localhost
t=2020-04-05T15:16:11+0100 lvl=info msg=“Request Completed” logger=context userId=0 orgId=0 uname= method=PUT path=/api/user/password status=401 remote_addr= time_ms=0 size=26 referer=

what would cause status=401 ?

Which installation method did you use to install Grafana?

Did you manage to log in successfully first and then you got an error on this screen?

That’s where it’s happening to me.


I have this same problem

My firmware:
Raspberry Pi 3B+
Openplotter 1.2.0

Done so far:
followed the commands in the page:
used "Ubuntu and Debian (Armv7)

Downloading grafana_6.7.3_armhf.deb and installation seemed to pass ok.

I knew that SignalK-server uses port 3000 (comes with the Openplotter),
therefore I changed the line in the file “/etc/grafana/grafana.ini” from “;http = 3000” to “http = 3030”.

Started Chromium-browser and used address “localhost:3030”, login page loaded ok, used admin-admin to log in, which was ok.

Then I tried to change the password, pressing “save” generated a red rectangle with the text “Unauthorized”. Pressing “Skip” throws me back to first login page, and by using admin-admin again I get the change password page and so on…

Any ideas ??

I have not yet made grafana-server to start automatically on boot.

wbr Eko

@Eko: By any chance did you tried with a different browser other than Chrome. If not I would suggest you to do that. Try logging in with IE or Edge. You should be able to change the password as well as can login to the home page.


1 Like

Hello Avin,

I did download and install Firefox, but it suffered the same login-problem.

Rainerw suggested older grafana version and 6.6.2 works now fine for me.


@avin is right, I reopened in google chrome and it worked. Thank you. (y)