New Word Cloud Plugin

Hi! So I couldn’t find one so I made one.
It’s rough around the edges yet, it’s based on https://react-wordcloud.netlify.com/
I need to document it yet but it is intended to use with elasticsearch datasource.

It’s my first plugin (new to react too), any comments or suggestions would be welcome!


Screenshot from 2020-03-04 12-42-02

6 Likes

Hello,

Any advice to install it in grafana 6.6.1 ?

BR David

I’m actually using it in that version. Just clone the repository (or download this and extract it ) in grafana plugins directory. You should see it in grafana logs when it starts.

Ok cool. I see it now. Does it works with influxdb datasource ?

I haven’t tested that. You need some field of your query as a list of tokens, and then use group by terms.

here are my settings:

Screenshot from 2020-04-02 12-04-35

It works also with influx… Thank you.

1 Like

@raulsperoni Thanks for making this plugin! It worked great in 6.x. I’m having trouble with it in 7 and was wondering if some of the changes affected the plugin.

I get this error message on my existing wordcloud panels:
image

When I create a new panel and select the wordcloud panel from the visualization panel (on the right), as soon as I make a new panel I get this:

I tried downloading the plugin many ways. I used git to clone the repo to the plugins directory(/var/lib/grafana/plugins/), downloaded both the zip and tar.gz file to my computer then transfered the file grafana with scp(SFTP) before “unzipping” to the plugins directory, curl the download link (curl -X GET $LINK > $FILENAME and unzipping it in the plugins directory.

If you need to know anything else, feel free to ask! :smile:

Hey great to see that someone is finding this useful! :smiley: I’m yet to upgrade to 7, and will of course need to make this work.

So I’ll check this out as soon as I can and let you now.

1 Like

Thank you so much! I’m looking forward to it! I’m not a js dev but if there’s something I can do let me know. :smiley:

Hey, look the plugin was working for me even after upgrading grafana to 7, and honestly I don’t see any hint of what may be wrong in your case.

But, this was a good chance for me to try the new plugin arquitecture, so I upgraded everything to 7, moved the code to github and asked for this plugin to be in the list.

Yo can find the new version here: https://github.com/raulsperoni/magnesium-wordcloud-panel

As I said, comments and issues are welcome: https://github.com/raulsperoni/magnesium-wordcloud-panel/issues

I hope you try it out and let me know if it works.

Cheers

2 Likes

Looks great! Looking forward having this published!

1 Like

I like your panel, in my use case it’s very usefull !!

I just had to build it again because it didn’t work at first, I don’t know what was the issue

1 Like