New Relic + K6 Integration Issue

Hi Team,
I am facing an weird issue while integrating New Relic and K6. I am able to execute the below docker command successfully.
docker run
-d --restart unless-stopped
–name newrelic-statsd
-h $(hostname)
-e NR_ACCOUNT_ID=368****
-e NR_API_KEY=“44c12b05******************”
-p 8125:8125/udp

Where NR_ACCOUNT_ID is my NR account ID and NR_API_KEY is my API Key. I have copied both account id and api key from NR by navigating MyAccount → API Keys. I generated INGEST_LICENSE type key.

When I execute my K6 script with the below command
k6 run --out statsd /.js
I don’t see the metrics in my NR.

I tried to execute “docker logs newrelic-statsd” command and I see the error message “time=“2021-07-15T07:51:58Z” level=warning msg="[newrelic] failed to send, sleeping for 3.744768988s: received bad status code 403”. I am sure its related to NR account and key issue. But I couldn’t resolve/find any solution. Can someone help?

Below is my account info.

NOTE: I am using Mac OS and I unable to attach the snapshots here.


Hi, @satheeshpandianj welcome to the forum :tada:

On first glance the NR_ACCOUNT_ID in the command and the one in the screenshots are different. I am also not sure if it’s good idea to show your account ID :thinking:

In all cases this seems to come from the new relic statsd software, so maybe ask their support for help?

Hope this helps you and have a nice day!

Hi there, welcome :slight_smile:

From what I remember when testing with New Relic a few weeks ago, I think you need an API “insert key” instead of an “ingest license” one.

The NR UI is a bit confusing with this as API keys are managed on a separate page. For me this is:<your account ID>/manage/api_keys and looks like this:

Hope this helps, and like @mstoykov said, contacting NR support might be better if you need further help.

Thanks @mstoykov. It was a typo and I confirmed both account id passed in the docker command and shown in the snapshot are same. I am still unable to figure out the root cause of this issue.

Thank you @imiric I created an API key using insert key option and passed it in the docker command and result is same and don’t see the metrics in NR. I did execute curl command as well to see if that works or not. However, I saw invalid query command as a result.

If you guys find anything related to this, please post it here. Thank you again.

Any help in this regard is much appreciated

Hi @satheeshpandianj,

as @mstoykov suggested in a previous comment, this seems a problem generated from New Relic. Have you already tried to contact them? You can do it from here: