MySQL Datasource not refreshing data

Hi Community.

This is my first post here as I’m just starting with Grafana. So sorry if I missed something obvious that would have solved following question. Couldn’t find an answer regarding my problem.

  • I use Grafana with Docker on a Synology NAS
  • MariaDB10 on Synology host is configured to store the configuration
  • Datasource is another MariaDB10 on a Rasperry Pi3
  • Connection to data source is established (green confirmation box in UI and no log errors)
  • Dashboards are set up, queries work just fine.

So far so good. Everything works perfect … with Grafana 5.2.x …

… but pulling the Docker image with Grafana 5.3.x (everything else the same, tried 5.3.0 and latest) my graphs are no longer updated with new data points from the database (checked database itself, the data is there). No error message, nothing, data is just not updated at all or if I’m lucky with high delay (about 1 hour).

I recognised there are a lot improvements regarding SQL in the changelog of grafana 5.3.x
Have I missed some breaking changes? Do I have to adjust my queries? Someone else seen a similar behaviour?

Thanks for any feedback. For the moment I just switched back to 5.2.5 version - thanks Docker…:wink:


Think this is related to an issue with timezone and the time filter, fixed in upcoming 5.3.3 release

Thanks for your reply.
So I will wait for the new release and test with this image.