MSSQL query timeout


We are running a SQL query. On our MSSQL it’s working fine after 5min of running.
When i past the same query on Grafana, i get the error message :
504 Gateway Time-out. The server didn’t respond in time

How could i increase the query timeout on Grafana side ?


Which version Grafana you use?

I had some timeout issues that were fixed with the newer version of Grafana (6.2.x). It is also important that you optimize query execution time by using index on tables.

We are using Grafana 6.2.2
With a short range query our report is working (1d) and when we increase it for more days (7d) we get this error.
THis is not on DB side because it’s working with another software (that we want to replace by grafana)

I think Grafana is for use with fast return queries. So to work in your case think of a way to structure a table with the pre-summarized index data where the calculation of the queries used in Grafana returns quickly.

yeah that a way to fix it, but i have not only one but many report with huge amount of data to request. That doesn’t matter the time that will take to display the data but i need to be able to see it.
If there is no way to increase this “timeout”

Try increment time there, Grafana 6.3.2:

Hi Alexandre,

I try it on grafana 6.3.2 and change all this parameter. still got the error when there is too much data to request :frowning:

with view materialized it’s working but i want to avoid this solution

Did you found a solution? I have the same problem.

No the only way is to have a store view with few data. You can’t request huge quantitiy of data with grafana from SQL DB. otherwise go through Elastics