Millibar shows as bars

I can see this is question is already asked, but isn’t it wrong behavior?

I have set left Y axis to Millibar and I want to see it like this:

1020 mbar
1015 mbar
1010 mbar

But instead I see:

1.020 bar
1.015 bar
1.010 bar

Any idea how to get it right. See picture below. The data I’m getting in is like this:


The unit adapts to the value so 1000 millibars is a 1 bar

I understand that. But in int his particular case of atmospheric pressure, there should be a way to stop this adaptation. Atmospheric pressure is always given as mbar value and never on bar value.

@cpeters asked a similar question in 2017: Prevent switching from millibar to bar

He eventually got around the issue by setting the unit to “none”.