Meta Query plugin issue with grafana 8.3.2

Earlier I was using Grafana 7.5.2 and meta query was working perfectly over there.
Recently I upgraded my Grafana to 8.3.2 and installed the meta query plugin but I am not able to use it. It says:

Datasource [object Object] was not found

And plugin is also Unassigned.

Any help would be appreciated

Any suggestion on this ?

Same to me
Captura de pantalla 2021-12-22 a las 13.00.01

Grafana version: 8.3.3
allowed unsigned plugin

Any luck on this ivansanchez?

I have been on vacation but I am still looking for a solution to this inconvenience.
I have managed to get the unsigned plugin supported, though.

Could you pls let me know how did you manage the unsigned plugin support.


Adding to grafana.ini:

allow_loading_unsigned_plugins = "plugin1, plugin2, plugin3"

you will permit the unsigned plugins in your Grafana.

I tried this but still getting the same error (Datasource [object Object] was not found)

allow_loading_unsigned_plugins = goshposh-metaqueries-datasource

We have the same error

You need to replace all expressions like:

"datasource": {
“uid”: “a4fcTGJnk”,
“type”: “goshposh-metaqueries-datasource”


"datasource": “MetaQueries”,
Go to Query inspector ->JSON and do it))

We also need to inform the plugin developer about this problem in new versions of grafana

I tried this but no luck :frowning:

You need to replace ALL datasources in query. It`s work for me…

Don’t know I have replace it everywhere but no luck.

cat tt | grep datasource
“datasource”: “MetaQueries”,
“datasource”: “MetaQueries”,
“datasource”: “MetaQueries”,
“datasource”: “MetaQueries”,

And now error turns to :

Cannot set properties of undefined (setting ‘hide’)

@nirajkumarpandey i was thinking on upgrade graphana. Its metaquery plugin working now ?

No I am using version 8.2.3 and it’s not working over there.

Did we able to resolve the issue any how , i am also facing same with 8.4.1. version?