Ldap authentication permission denied on the pem file

Dear Team,

I am finding difficulty with ldap authentication and keep getting the below error when attempting to logon.
grafana-server: t=2019-10-09T14:10:23+0100 lvl=eror msg=“Error while trying to authenticate user” logger=context userId=0 orgId=0 uname= error=“open /etc/openldap/cacerts/authconfig_downloaded.pem: permission denied”

I have tried increasing the log level, by following instructions as
mode = console
filters = ldap:debug

However i am not getting any more details other than the above error.
Have regenerated the authconfig to ensure there is nothing wrong.

I can connect using openssl connect
openssl s_client -connect :636 -CAfile /etc/openldap/cacerts/authconfig_downloaded.pem and it perfectly connects

Please let me know what to be checked

I am afraid that it is not a Grafana problem but SO permission mismatch between grafana service owner and your pem file.

Agree, it is resolved now. It was an oversight. And once i changed it worked. Can close this now.