It all turned white, but I'm in dark mode!

Hi community!
After some key combination (I don’t know what I’ve typed since I thought I was typing into a form but…I wasn’t :see_no_evil:), all Grafana turned white:

Before it was all black (I was in default mode, so I guess it was dark).
I’ve tried switching to dark and to light mode, but it doesn’t change anything.

Hi @pereus,

Incase not, then try to set it to dark mode from the settings area and click save as shown in the screenshot;

gnome-shell-screenshot-1RTAT1

If that does not change then logout and religion

And even if then does not help, then try to clear browser cache n cookies and test it (you can also test it on a new browser or incognito mode).

I hope this helps.

Hi @usmanahmad ,
thanks for your answer.
I’ve tried everything you suggested me, but nothing worked. I’m using Grafana in 2 different computers and the problem is the same on both.

Hi @pereus,

Ok, hmm then might be that the settings are now permanent. Please open the grafana.ini configuration file and find the parameter default_theme

There set it to this;

default_theme = dark

Restart the grafana-server and then it should be back to dark mode

@usmanahmad I’ve done it and…it’s still all white :sob:
What the heck have I done?

Can you paste here the part of the configuration where you set it as:

default_theme = dark

thanks

Here it is:

# Default UI theme ("dark" or "light")
default_theme = dark

It was already there, I just had to uncomment it.

1 Like

Ok, one last question on this.

Did you try out a different browser to be able to change from the WebUI?

Yes, I’ve tried Firefox, Firefox incognito, Chrome and Chrome incognito. Always the same.
Thanks for taking the time to analyse this with me!

What file in what folder are you editing?

/etc/grafana/grafana.ini

Ok, I think this might be a bug because when I changed the configuration from black to white while the UI theme is different from what I had defined in the configuration file. The changes did not take effect until manually did it inside the UI.

I will try to get in touch with our team.

@pereus What grafana version you are using?

Thanks!
I’m using v9.1.6 (92461d8d1e)

Hi @pereus,

I have reported this issue at our GitHub

It will be nice if you also keep track of it because I have provided all the possible details from my machine but as your case if a bit different (as do not know what activated the change).

So if there are any questions asked by the developers, please try to answer it with as much details as you can.

Thanks

Thanks, I’ll keep an eye on it!

Hey @pereus

Please check the GitHub link as just got an update about it. Alteast it’s not a bug, instead a special developer feature to toggle themes.

There is an explanation + answer for this.

I hope this helps.

1 Like

Checked and solved!
Damned tt shortcut!!!
Thanks again for the help!

1 Like