Issues with k6-operator setup on local instance of k8s cluster

Hey, I have been working with k6-operator for a month now on my local k8s cluster using rancher-desktop for testing a few stuff, it was working but for a couple of days, it is throwing an ErrImagePull error. Seems like the manager container is somehow not fetching the image now from the container registry. The exact error is mentioned below:

Failed to pull image “Package operator · GitHub”: rpc error: code = Unknown desc = no matching manifest for linux/arm64/v8 in the manifest list entries

Does someone has an idea regarding this issue? I tried it on other platforms such as Linode, and it is working as expected.

Hi @anuragjanghala

Welcome to the community forums :wave: and thanks for reporting this.

There was a recent beta release and it seems docker pull does not have an arm64 build. Are you running on arm64 platform? That also explains it working on other platforms for you (Linode).

It worked a couple of days ago with docker pull, which did have an arm64 build.

We are looking into it. I’ll keep you posted.


Hi, Thanks for the clarification I’m using arm64 device. How much time will it take to get support on these devices?

Hi @anuragjanghala

We did have the arm64 build in previous releases, so I hope we can find out what happened this time and fix it. The operator team is looking into what failed with this build and we should have more information in the following days.


1 Like

Hi @anuragjanghala

I can see @olha already explained the issue in Support for linux/arm64/v8 devices such as (m1 mac) · Issue #187 · grafana/k6-operator · GitHub.

There was a misunderstanding on my part

the operator has NOT supported arm64 at all, in any version. So the issue you encountered has a different cause.The v0.0.9rc2 build has broken Docker manifests, due to an issue in underlying CI dependency. So the problem you encountered with v0.0.9rc2 is not related to ARM architecture.

I tested docker pull on my MacOS and it works now as it did previously with v0.0.9rc1.

And indeed my MacOS returns

        "Architecture": "amd64",
        "Os": "linux",

with docker inspect | grep -A1 'Architecture'. So the Docker manifests were broken.

Again thanks for reporting this. Enjoy the weekend!