Is it possible to insert in dashboard an existing web page

Morning,
I have try tu use iframe balise html, but not results.
firstly is it possible to do this?
Is there a data source for this?
regards

1 Like
1 Like

Thank you but it’s the opposite that I would like to do, integrate a graph from web page into a grafana board.

2 Likes

<iframe src="https://www.zeitverschiebung.net/clock-widget-iframe-v2?language=en&size=small&timezone=Africa%2FJohannesburg" width="100%" height="90" frameborder="0" seamless></iframe>

You need to use the text panel, change it to html.
You also need to disable sanitize html in the grafana.ini
You also need to make sure you are not serving an https iframe on a non https grafana
You also might need to check you origin headers if you get CORS errors.

1 Like

ok for this

in my grafana.ini I have only this text, I don’t understand “sanitize”
[server]
–Protocol (http, https, socket)
protocol = http
–The ip address to bind to, empty will bind to all interfaces
;http_addr =
–The http port to use
http_port = 3000

my page web is http, and my grafana is http too, I think it is OK ?

I have adding in html code

<html> 
<body>
<iframe src="http://f5len.org/tools/OSM/index.html" width="100%" height="90" frameborder="0" seamless></iframe>
</body>
</html>

don’t run…I am forgotten something ? (same with your iframe example)
thank’s

Did you search for the word sanitize in your ini?

yes in my grafana.ini I have only

[server]
# Protocol (http, https, socket)
protocol = http

# The ip address to bind to, empty will bind to all interfaces
;http_addr =

# The http port  to use
http_port = 3000

according to my research, sanitize is sort of transformation of html much secure.
before getting there, I would just like to display the html page in the dashboard.

you cant get there without changing that setting. Is that all you have in your ini file just those few lines under [server] ?

1 Like

Yes just these lines.

as indicated by @jangaraj add this line then restart grafana

[panels]
disable_sanitize_html = true

for jangaraj and yosiasz
I have added:

[panels]
disable_sanitize_html = true

same, don’t run

show us what you added in your ini?

Also did you restart grafana service?

no, but after restart it is OK :clap: thank’s alls

2 Likes