Interval is always calculated lower than expected (InfluxDB)


I have two influxdb source both has the min interval setting set to 10s. This is our data insert interval.
I have some graphs where the range is quite big, now-2d–now but the interval is calculated to 1m if I set it to -7d the interval changes to 5m.
The problem is we have graphs with multiple queries and with this interval we hit the datapoint limit so not everything is plotted. I am not sure what is the expected resolution for a 2 day period or not. To me 1 min sounds a but too small. If it is unexpected any idea what can cause this? I tried the legacy interval and the new __interval variables, I tried to override it from url (could not do it) but had no effect.

Thanks for the help

There is no general expected resolution - it depends on the granularity of your data + probably you don’t want to kill browser with millions of datapoints in the graph visualization.

I recommend to create and use own interval dashboard variable for time aggregation and customize auto option there (if you want to use auto option - you can still select aggregation time manually):

Thank you for your help, I will check this out