Infinity Plugin post parameters -d format

I am successfully executing this Adobe Analytics (reporting) curl via a cmd prompt, and it is returning results:

curl -i -H “Accept: application/json” -H “Content-Type: application/json;charset=utf-8” -H “x-gw-ims-org-id: xxxx” -H “x-gw-ims-user-id: xxxx” -H “x-proxy-global-company-id: xxx” -H “x-request-id: 33756xxxx” -H “x-request-entity-id: 64exxxx” -H “x-request-client-type: AW” -H “Authorization: Bearer xxxxx” -H “x-request-timing-group-id: 0f4cd65aea1a4b1cac1664437197020a” -H “x-request-entity-name-base64: Rmxxxxx” -X POST -d “{"rsid":"schopreprodmain","globalFilters":[{"type":"dateRange","dateRange":"2023-08-10T00:00:00.000/2023-08-29T00:00:00.000"}],"metricContainer":{"metrics":[{"columnId":"metrics/visitors:::0","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_1"]},{"columnId":"metrics/visits:::2","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_3"]},{"columnId":"metrics/visitors:::4","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_5"]},{"columnId":"metrics/visits:::6","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_7"]},{"columnId":"metrics/visitors:::8","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_9"]},{"columnId":"metrics/visits:::10","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_11"]}],"metricFilters":[{"id":"STATIC_ROW_COMPONENT_1","type":"segment","segmentId":"s300006512_64667b2f04125c2ea1d92939"},{"id":"STATIC_ROW_COMPONENT_3","type":"segment","segmentId":"s300006512_64667b2f04125c2ea1d92939"},{"id":"STATIC_ROW_COMPONENT_5","type":"segment","segmentId":"s300006512_64e8bfe44087e77f62a1cd28"},{"id":"STATIC_ROW_COMPONENT_7","type":"segment","segmentId":"s300006512_64e8bfe44087e77f62a1cd28"},{"id":"STATIC_ROW_COMPONENT_9","type":"segment","segmentId":"s300006512_64e8c02d8cdbcb21c01e273a"},{"id":"STATIC_ROW_COMPONENT_11","type":"segment","segmentId":"s300006512_64e8c02d8cdbcb21c01e273a"}]},"settings":{"countRepeatInstances":true,"includeAnnotations":true},"statistics":{"functions":["col-max","col-min"]},"capacityMetadata":{"associations":[{"name":"applicationName","value":"Analysis Workspace UI"}]}}” https://appservice-reporting5-1.omniture.com/reporting/1.0/analytics/users/reports/ranked?locale=en_US

However, when I execute it via the Infinity Plugin it returns: Status: 500. Message: error getting data frame. 400

This is the same query from the Grafana Infinity Query Inspector (I setup all the http headers in Infinity):

curl -X ‘POST’ -d '{"rsid":"schopreprodmain","globalFilters":[{"type":"dateRange","dateRange":"2023-08-10T00:00:00.000/2023-08-29T00:00:00.000"}],"metricContainer":{"metrics":[{"columnId":"metrics/visitors:::0","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_1"]},{"columnId":"metrics/visits:::2","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_3"]},{"columnId":"metrics/visitors:::4","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_5"]},{"columnId":"metrics/visits:::6","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_7"]},{"columnId":"metrics/visitors:::8","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_9"]},{"columnId":"metrics/visits:::10","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_11"]}],"metricFilters":[{"id":"STATIC_ROW_COMPONENT_1","type":"segment","segmentId":"s300006512_64667b2f04125c2ea1d92939"},{"id":"STATIC_ROW_COMPONENT_3","type":"segment","segmentId":"s300006512_64667b2f04125c2ea1d92939"},{"id":"STATIC_ROW_COMPONENT_5","type":"segment","segmentId":"s300006512_64e8bfe44087e77f62a1cd28"},{"id":"STATIC_ROW_COMPONENT_7","type":"segment","segmentId":"s300006512_64e8bfe44087e77f62a1cd28"},{"id":"STATIC_ROW_COMPONENT_9","type":"segment","segmentId":"s300006512_64e8c02d8cdbcb21c01e273a"},{"id":"STATIC_ROW_COMPONENT_11","type":"segment","segmentId":"s300006512_64e8c02d8cdbcb21c01e273a"}]},"settings":{"countRepeatInstances":true,"includeAnnotations":true},"statistics":{"functions":["col-max","col-min"]},"capacityMetadata":{"associations":[{"name":"applicationName","value":"Analysis Workspace UI"}]}}
’ -H ‘Accept: application/json;q=0.9,text/plain’ -H ‘Authorization: xxxxxxxx’ -H ‘Content-Type: xxxxxxxx’ -H ‘X-Gw-Ims-Org-Id: xxxxxxxx’ -H ‘X-Gw-Ims-User-Id: xxxxxxxx’ -H ‘X-Proxy-Global-Company-Id: xxxxxxxx’ -H ‘X-Request-Client-Type: xxxxxxxx’ -H ‘X-Request-Entity-Id: xxxxxxxx’ -H ‘X-Request-Entity-Name-Base64: xxxxxxxx’ -H ‘X-Request-Id: xxxxxxxx’ -H ‘X-Request-Timing-Group-Id: xxxxxxxx’ ‘https://appservice-reporting5-2.omniture.com/reporting/1.0/analytics/users/reports/ranked?includeOberonXml=true&locale=en_US&useResultsCache=true

I suspect, my -d in the Infinity post setup has wrong syntax. This is what I have in Infinity under URL Options under POST, body type Raw, Body Content, as one single line:

{"rsid":"schopreprodmain","globalFilters":[{"type":"dateRange","dateRange":"2023-08-10T00:00:00.000/2023-08-29T00:00:00.000"}],"metricContainer":{"metrics":[{"columnId":"metrics/visitors:::0","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_1"]},{"columnId":"metrics/visits:::2","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_3"]},{"columnId":"metrics/visitors:::4","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_5"]},{"columnId":"metrics/visits:::6","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_7"]},{"columnId":"metrics/visitors:::8","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_9"]},{"columnId":"metrics/visits:::10","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_11"]}],"metricFilters":[{"id":"STATIC_ROW_COMPONENT_1","type":"segment","segmentId":"s300006512_64667b2f04125c2ea1d92939"},{"id":"STATIC_ROW_COMPONENT_3","type":"segment","segmentId":"s300006512_64667b2f04125c2ea1d92939"},{"id":"STATIC_ROW_COMPONENT_5","type":"segment","segmentId":"s300006512_64e8bfe44087e77f62a1cd28"},{"id":"STATIC_ROW_COMPONENT_7","type":"segment","segmentId":"s300006512_64e8bfe44087e77f62a1cd28"},{"id":"STATIC_ROW_COMPONENT_9","type":"segment","segmentId":"s300006512_64e8c02d8cdbcb21c01e273a"},{"id":"STATIC_ROW_COMPONENT_11","type":"segment","segmentId":"s300006512_64e8c02d8cdbcb21c01e273a"}]},"settings":{"countRepeatInstances":true,"includeAnnotations":true},"statistics":{"functions":["col-max","col-min"]},"capacityMetadata":{"associations":[{"name":"applicationName","value":"Analysis Workspace UI"}]}}

Would this be the correct syntax?

When you execute what? Can you share your infinity setup and query minus sensitive stuff

I already gave the Grafana query. It is given below. How would I share the Infinity setup?

This is the Grafana Infinity query from Query Inspector:

curl -X ‘POST’ -d '{"rsid":"schopreprodmain","globalFilters":[{"type":"dateRange","dateRange":"2023-08-10T00:00:00.000/2023-08-29T00:00:00.000"}],"metricContainer":{"metrics":[{"columnId":"metrics/visitors:::0","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_1"]},{"columnId":"metrics/visits:::2","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_3"]},{"columnId":"metrics/visitors:::4","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_5"]},{"columnId":"metrics/visits:::6","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_7"]},{"columnId":"metrics/visitors:::8","id":"metrics/visitors","filters":["STATIC_ROW_COMPONENT_9"]},{"columnId":"metrics/visits:::10","id":"metrics/visits","filters":["STATIC_ROW_COMPONENT_11"]}],"metricFilters":[{"id":"STATIC_ROW_COMPONENT_1","type":"segment","segmentId":"s300006512_64667b2f04125c2ea1d92939"},{"id":"STATIC_ROW_COMPONENT_3","type":"segment","segmentId":"s300006512_64667b2f04125c2ea1d92939"},{"id":"STATIC_ROW_COMPONENT_5","type":"segment","segmentId":"s300006512_64e8bfe44087e77f62a1cd28"},{"id":"STATIC_ROW_COMPONENT_7","type":"segment","segmentId":"s300006512_64e8bfe44087e77f62a1cd28"},{"id":"STATIC_ROW_COMPONENT_9","type":"segment","segmentId":"s300006512_64e8c02d8cdbcb21c01e273a"},{"id":"STATIC_ROW_COMPONENT_11","type":"segment","segmentId":"s300006512_64e8c02d8cdbcb21c01e273a"}]},"settings":{"countRepeatInstances":true,"includeAnnotations":true},"statistics":{"functions":["col-max","col-min"]},"capacityMetadata":{"associations":[{"name":"applicationName","value":"Analysis Workspace UI"}]}}
’ -H ‘Accept: application/json;q=0.9,text/plain’ -H ‘Authorization: xxxxxxxx’ -H ‘Content-Type: xxxxxxxx’ -H ‘X-Gw-Ims-Org-Id: xxxxxxxx’ -H ‘X-Gw-Ims-User-Id: xxxxxxxx’ -H ‘X-Proxy-Global-Company-Id: xxxxxxxx’ -H ‘X-Request-Client-Type: xxxxxxxx’ -H ‘X-Request-Entity-Id: xxxxxxxx’ -H ‘X-Request-Entity-Name-Base64: xxxxxxxx’ -H ‘X-Request-Id: xxxxxxxx’ -H ‘X-Request-Timing-Group-Id: xxxxxxxx’ ‘https://appservice-reporting5-2.omniture.com/reporting/1.0/analytics/users/reports/ranked?includeOberonXml=true&locale=en_US&useResultsCache=true

I resolved this. Had to change the syntax in -d in Infinity.