Image is not coming in grafana alert email notification

Hi All,

I am not getting image in the Grafana Alert notification email… i have downloaded the grafna image render zip file onto “/var/lib/grafana/plugins” path and unziped it (as i was not able install this image render through “grafana-cli” )

I have installed Prometheus and Grafana on same Ubuntu server.

Ubuntu version: 20.04.1
Grafana Version: 7.3.2
Prometheus Version: 2.22.1
Image render plugin version: grafana-image-renderer-3.0.1.linux-amd64.zip

i think the reason for error is the server_url specified in above rendering sectin is not up and running. how to make that url up…


Error Log from Grafana.log file

t=2021-07-26T01:21:30+0000 lvl=info msg=“New state change” logger=alerting.resultHandler ruleId=3 newState=ok prev state=alerting
t=2021-07-26T01:21:30+0000 lvl=info msg=Rendering logger=rendering renderer=http path=“d-solo/jTx7Zmzik/alerts-windows-nodes?orgId=1&panelId=5”
t=2021-07-26T01:21:30+0000 lvl=dbug msg=“calling remote rendering service” logger=rendering renderer=http url=“http://10.201.72.13:8081/render?deviceScaleFactor=1.000000&domain=10.201.72.13&encoding=&height=500&renderKey=uFPfHgRSxWvaJ9ogsbUCsyqtSPuBaRFf&timeout=15&timezone=&url=http%3A%2F%2F10.201.72.13%3A3000%2Fd-solo%2FjTx7Zmzik%2Falerts-windows-nodes%3ForgId%3D1%26panelId%3D5%26render%3D1&width=1000
t=2021-07-26T01:21:30+0000 lvl=eror msg=“Failed to send request to remote rendering service.” logger=rendering renderer=http error=“Get “http://10.201.72.13:8081/render?deviceScaleFactor=1.000000&domain=10.201.72.13&encoding=&height=500&renderKey=uFPfHgRSxWvaJ9ogsbUCsyqtSPuBaRFf&timeout=15&timezone=&url=http%3A%2F%2F10.201.72.13%3A3000%2Fd-solo%2FjTx7Zmzik%2Falerts-windows-nodes%3ForgId%3D1%26panelId%3D5%26render%3D1&width=1000”: dial tcp 10.201.72.13:8081: connect: connection refused”
t=2021-07-26T01:21:30+0000 lvl=eror msg=“Failed to render and upload alert panel image.” logger=alerting.notifier ruleId=3 error="Failed to send request to remote rendering service.
t=2021-07-26T01:21:30+0000 lvl=info msg=“Sending alert notification to” logger=alerting.notifier.email addresses=[umesha.d@cmd.com] singleEmail=false


Below are my My rendering settings in /etc/grafana/grafana.ini file
[rendering]
server_url = http://10.201.72.13:8081/render
callback_url = http://10.201.72.13:3000/
concurrent_render_request_limit = 30

Please help with above issue…

Did you already install the package that needed for image rendering?

https://grafana.com/docs/grafana/latest/administration/image_rendering/

Also you need to install chromium-browser.