I have a big Problem with the X-Axis

you share a screen where the query is working as expected :

from(bucket: "DBANDY1")
  |> range(start: v.timeRangeStart, stop: v.timeRangeStop)
  |> filter(fn: (r) => r["_measurement"] == "Ventilator_gestern" or r["_measurement"] == "Kuehlschrank_gestern" or r["_measurement"] == "Imac_gestern" or r["_measurement"] == "FeFo_TV_gestern" or r["_measurement"] == "Drucker_gestern")
  |> filter(fn: (r) => r["_field"] == "value") 
  |> window(every: 1d)
  |> group(columns: ["_start","_measurement"])
  |>last()
  |> group(columns: ["_measurement"])

don’t forget to configure the Xaxis option :slight_smile:
or please precise us if it’s not what you expected and why this is not conform

To apply this to your other query you can copy and paste this part of the query where you need to have the same transformation

  |> window(every: 1d)
  |> group(columns: ["_start","_measurement"])
  |>last()
  |> group(columns: ["_measurement"])

this part permit you to get one result by day as you was asking

If I take the script as you suggested, then all the data has disappeared in the X-Ache and there is only “value”
I was able to adjust my overrides without any problems, but where do I set it so that the X-axis shows the consecutive days once. It’s either harder than I thought, or I’m being really stupid

image

Sorry, if I leave the old script in Query, I only have the following choices - see Screenshot-1
If I use the new script, I have no option at all and cannot enter it manually - see Screenshot-2


Sorry, I can understand that I might annoy you, but could you please be so kind and explain to me based on my last post how exactly I have to set this up.

can you take my query and use it again and show us data received by the grafana panel, or if you can run the query in ibfluxdb too and show us,
We took your data and reproduce exactly your situation, you should have the same result. we have to understand what happen .

When I use your query in Grafana, I get my board like this, which means that there is only the word Value in the X-axis.
If I use the query in the Influx, the raw data looks like this.



Hello !
it’s perfect you just have to choose right X-Axis option and it’s all good,
you can scroll down this menu be carefull, try to find _stop field like on my screen

Good morning,
Unfortunately, it’s not quite perfect yet, because the X-axis now shows a time, but unfortunately no date per day.

Do you have an idea how I can solve the problem? After all, the date should be on the X-axis under the bars and not a time, as is the case now.

Warm greetings
andy

my man i can see from here you have only 6 hours time range on your screenshot…
i think you should try a bit more before posting

You’re right, that was my mistake -sorry- now it seems to fit and I’ll watch it for 2-3 weeks.