HTTP post request fails with IP blacklisted error

I have a script that does some load testing. It makes post requests to an EC2 machine in AWS backed behind a firewall.
When I run scripts locally with k6 run script.js, the request succeeds. I can call the endpoint of the resource hosted in AWS.
When I run with the cloud option, k6 cloud script.js it fails with error:

 IP (10.219.xx.xx) is in a blacklisted range (  instance_id=0 lz="amazon:us:ashburn" test_run_id=1146113

That is not even my IP address. And I’m not blacklisting any IP in my script

Does it automatically blacklist this IP address?
These are my options:

    httpDebug: 'full',
    ext: {
        loadimpact: {
            name: 'activation load testing',

It seems I was mixing up k6 cloud script.js with k6 --out cloud script.js
From Cloud :

Don’t confuse k6 --out cloud script.js (what this page is about) with k6 cloud script.js. While the former means that you run k6 locally and stream the result to the cloud, the latter means that you upload your script to k6 cloud and tell the cloud infrastructure to run the entire test for you. In this case you’ll only see status updates in your CLI, but in all cases you’ll be able to see your test results at