Error 1110: Blacklisted IP when running on other machine

I am trying to do a load test to an API which is on a different computer (with a ubuntu VM) in the same network on IP When I access the routes via postman everything works fine, but when I run a test, every request fails, with error 1110. I searched on this community and found nothing exactly like this. Am I doing something wrong?

I have the firewall disabled on my virtual machine and I can access the routes from anywhere. I also tried to run the test directly on the VM using the localhost IP ( but the result was the same.


Hi there, welcome to the forum :slightly_smiling_face:

the IP range is reserved for private (LAN) addresses, and they are unreachable over the public internet. The k6 Cloud blocks certain IP ranges to prevent abuse, and to notify you if you try to connect to them, like in this case.

If you want to load test a service using the k6 Cloud, then you need to ensure that the service is reachable over the internet via a public IP. This is not something we can help you here, and you’ll need to set it up yourself, or talk to your operations team.

Otherwise, if the service is reachable locally via Postman, then it should also be reachable with a local k6 test run, just not from k6 Cloud.