How to use variable with * on ELK keyword field?

I have a variable TestScenario with the value *. I use a Lucene query for the ELK data source:

testScenario:$TestScenario

The ELK field testScenario is of keyword type, and I do not get any results. I only get results for fields of text type or when I don’t use a variable like this: testScenario:*.

Grafana sends \\* instead of *, which is the problem.

How can I force Grafana to use the variable correctly?"

check out the different variable syntaxes, maybe one will work for your case:

I have found one workaround - to use a query variable instead of a custom variable. Query variables have an “All” option. So, problem solved. :blush:

1 Like