How to show multiple rows in one table

hello everyone,

since i am new at grafana i need some support.
I’m using Grafana 7.3.6 with Prometheus, gathering information from our k8s cluster.
I have created a table panel which contains some informations about used version for different deployed apps.The data which populate the table rows are based on “multi-value” variable.My issue on this matter is that if i select two or more values i can see only one row in table,i would expect more rows,depending on the selected values.
E.g this is the multi value variable which is called “release”
grafik

and this is the result

Unfortunately i can see only one row.I am selecting two values(cpd and dsg) from variable,so i would expect to get one table with two rows
A workround is to use the Repeat option but it looks not so nice as i want.For many values i will get many tables.Therefore i like to combine all rows/information in one table.

Could this be possible in Grafana?I hope my idea is clear to you.

BR
Oltion

I suggest you post your actual query so people can see what you have, along with all the Grafana query settings you have set for it.

What you are seeing is correct as the panel is being repeated for each variable so nothing odd at all about it.

What you want to do is to rather use the variables as a filter to see only those variables you wish in a single table.

To do this write a query that returns all the variables in a single query and then use the variable drop-down list to filter only those you wish to see.

Another way to do this is to use the variables to create a comma-separated list for your query ie

WHERE release in (‘variable1’, ‘variable2’, …, ‘variablen’)

In this way, the query will return only the variables you select but will require a new query each time whereas using a filter will not.

many thnx for your response.I am using the the pre-defined promethues metric “kube_deployment_labels” and for my purpose i added the variable release as filter within the metric.So my metric looks like now
kube_deployment_labels{deployment="$release"} and in order to achieve my goal the solution was easier as i thought.Only the operator ~ makes the difference :slight_smile:

So my query must be as follow
kube_deployment_labels{deployment=~"$release"}