How to exploit the UCD-SNMP-MIB laLoad table with the TIG stack?

Hi,
I use the Telegraf InfluxDB Grafana Stack.
I work with the UCD-SNMP-MIB and I can Exploit almost each OID except the Load Average.
In the MIB this metrics “loadaverage” are under the laTable (.1.3.6.1.4.1.2021.10) with the laLoad OID (.1.3.6.1.4.1.2021.10.1.3).
The problem is that this oid returns the three values (1, 5, 15 minutes load average). So I tried the three OID :

Load 1 : .1.3.6.1.4.1.2021.10.1.3.1
Load 5 : .1.3.6.1.4.1.2021.10.1.3.2
Load 15 : 1.3.6.1.4.1.2021.10.1.3
I can see these values in InfluxDB but I can’t display them (no data) on Grafana.
So I thought "may be it is because we have a table in a table and we can’t manage this case) …

Did someone tried to exploit load average with snmp ?

Thank you for your help !

If you have the data in influxdb you can query it from. Grafana, what does your influxdb query look like and what is the response from influxdb?

1 Like

Hi, thank you for answering,

Yes, in InfluxDB I have 3 columns with the load average (1, 5, 15) (I don’t know how to send screenshot there).

In Grafana I can see the names I choosed for them (load1 ,load5, load15) in Telegraf.

But when I configure Grafana it is written “no data”.

I don’t have the problem with other OID from this MIB if they are not grouped in a table.

Edit :

I can show the MIB and the OID (highlights) in the screen below. You can see this OID “.1.3.6.4.1.2021.10.1.3” gives the 3 loads.

Or May be it is the format (string) ?

Must be something with your query or maybe the data. Open query inspector and inspect the response from InfluxDB:

Hi,
I have some news that I’ll try to explain.

Now I can get the load average from the UCD-SNMP-MIB, but only the Int values (percentage).

What I did for that :

1- My Telegraf conf (input SNMP):

[[inputs.snmp]]
agents = [ “XXX.X.X.X:161” ]

timeout = “5s”
retries = 3
version = 2
community = “public”

name = “test”

[[inputs.snmp.field]]
name = “memTotalFree”
oid = “.1.3.6.1.4.1.2021.4.11.0”

[[inputs.snmp.field]]
name = “cpu_percent”
oid = “.1.3.6.1.4.1.2021.11.9.0”

[[inputs.snmp.field]]
name = “Ram_Used”
oid = “.1.3.6.1.4.1.2021.4.6.0”

[[inputs.snmp.table]]
#measurement name
name = “la_Table_I”
#inherit_tags = [ “” ]
oid = “.1.3.6.1.4.1.2021.10”

#[[inputs.snmp.table.field]]
#name = “load1-float”
#oid = “.1.3.6.1.4.1.2021.10.1.6.1”
#[[inputs.snmp.table.field]]
#name = “load5-float”
#oid = “.1.3.6.1.4.1.2021.10.1.6.2”
#[[inputs.snmp.table.field]]
#name = “load15-float”
#oid = “.1.3.6.1.4.1.2021.10.1.6.3”
#is_tag = true

2- Explanation :

I’ve declared the laTable “.1.3.6.1.4.1.2021.10” :

[[inputs.snmp.table]]
name = “la_Table_I”
oid = “.1.3.6.1.4.1.2021.10”

3- In Grafana I have the measurement “la_Table_I” and I can choose laindexes 1, 2, 3 wich refers to load1, load5 and load15 :

load_graf

I can choose the values in the table (laConfig …laLoad, laLoadInt …) :

load_graf2

Some remarks :

  • I only can graph the laLoadInt, no other field from this table…

  • Furthermore, some fields are missing from this table if you compare to what the UCD-SNMP-MIB offers (look at the screenshot in my first) for instance, laLoadFloat doesn’t appear.

  • I just had to add the snmp table, I tried with other OID as you can see in commentaries at the end of the telegraf conf, but this didn’t work.

Does anybody can explain why ?

Thank your for your time !