How should I input the value of cert_file/cert_key in grafana.ini for the tls secret on k8s

Hi,

I deployed Grafana Helm Chart (v7.0.5) / AppVerion (v10.1.5) in our cluster and I created secret tls and configured ingress with url / tls in helm, and then set the alerting in grafana after deployment with customized helm chart.

However, even if ingress with tls secret is configured in helm chart, default alert message includes port number “:3000” like this… Also, View URL button is not working properly because of the port number (":3000)

i found that there should be necessary items such as cert_file, cert_key and protocol in grafana.ini

I’m looking for how to set the deployed tls secret with cert_file/key.
How should I input the cert_file/cert_key value of grafana.ini for the tls secret that I already distributed to k8s?

  1. Secret with TLS
    kubectl create secret tls grafana --cert **.pem --key **.pem -n grafana

  2. grafana.ini
    [server]
    domain=test.company.co.kr
    protocal= https
    cert_file= [secret name ?? ]
    cert_key=[secret name ?? ]

Configure root_url option in the [server]section of the Grafana configuration file to match your ingress domain/protocol.

1 Like

@jangaraj Thanks :smile: it works fine.