How can I get rid of the pesky Grot?

Every time I visit a documentation page, even if I just reload it, Grot appears and asks me whether I want the page translated to German. Grot seems to be utterly unable to remember me saying “no, thank you” and also does not honor my browser settings, which have an empty list of preferred languages (Firefox).

This happens whether I am logged in or not. Is there any way to get rid of Grot entirely? I do not want to beta test chat bots while reading the docs!

1 Like

Hey @realulim - thanks for reaching out and sorry for the extra noise on the docs page. I checked with our web team and they mentioned clicking “no” on the consent banner will prevent the Grot bot from showing up in the future. Let me know if that doesn’t work for you.

Hey @elyssaemrich unfortunately there is no consent banner. If I click “no” to the question whether the page should be translated, then the same question appears again, when I reload the page or load another page. This is extremely annoying, because reading the docs obviously means I am jumping around a lot.

Hey @realulim - yes I can imagine that is annoying especially since that is not the intended experience. The consent banner is the same pop-up that you’re referring it. I’ve tested it out on my end and once I click “no” it does go away when I refresh or move to another page.

Do you happen to have any browser or extension blockers that would prevent the response being saved to localStorage?

I have uBlock Origin, Privacy Badger and I don’t care about cookies, but switching them off does not change the behavior. All I can see that seems unusual is that there is XHR request to https://grafana.com/canspam that gets a 403.

In any event, if you want to save something to local storage, there should be a consent banner for that, no? And if I don’t give consent, then the Grot should not even appear!

Hey @realulim - apologies this hasn’t been an easy fix. The pop-up is meant to be the consent (see screenshot below). Have you tried another browser by chance? I’ll follow-up with our web team, again to see if they have any suggestions based on the information you shared.

Hello @elyssaemrich , the popup doesn’t ask me for consent to saving to localStorage or setting a cookie. It just asks whether it should translate and summarize a page for me. If it were doing this right, then I would have the choice to not give consent and that would mean the web developers couldn’t count on the fact that they are able to save state in my browser. But they do not give me a choice, in fact they require me implicitly to consent if I don’t want to be annoyed by the banner. I don’t think that’s right.

That being said, I tried Chrome and it worked correctly with Chrome. Meaning that state was saved to the browser, even though I did not consent to this.

@realulim thanks for working with me to trouble shoot this. It sounds like you are not seeing the cookies consent banner at the base of webpage? Earlier I misunderstood our web team, I thought the banner they were referring to was the translation pop-up - but they were referring to the cookies consent. See the screenshot below. Do you see this banner when you visit our page?

No, I don’t see that banner in Firefox. In Chrome, yes.

Thank you for confirming! Our web team shared that it’s likely an issue on your Firefox extension. They don’t believe there is any fix we can do on our end.

A follow up … the same problem also appears with MS Edge. Deactivating all extensions in Firefox and/or Edge also doesn’t helped. Confirming the cookies doesn’t changes the behaviour neither in FF nor in Edge.

So, I would say that ths is indeed a problem on your site and not on the user side. Please deactivate this bot.

Hey @thomaszastrow - thanks for letting us know! To confirm, were you able to “accept” the black cookie notice at the bottom of the webpage? After that you can select “no” for the grotbot.

Very annoying. I am using Chrome and the same here. On every documentation visit or even on reloading a documentation page with F5 I am getting the Grot-Question again even after clicking “no”. After debugging I can say that the local storage item “grot-summary” is never set. If I set the item manually the question dissapears:

image

The following line does not work as your frontend developers might expect:

hi(“analytics”) leads to undefined and the local storage item will not be set.

1 Like

Thank you for sharing @tjamin! I do need to confirm that you’ve accepted the consent at the base of the page? See screenshot below:

Damn. Yes. That’s it! After clicking “Got it” on the “cookie banner” the grot popup only apears once and after clicking “No, thanks” it disappears. Thank you. Next time I will better read the existing conversation. You already asked the user realulim for the banner some weeks ago.

1 Like

Glad to hear that worked for you @tjamin! Our website team did recently merge a PR to update the message on the grotbot to highlight the need to accept the cookies banner. Hopefully that will make it easier moving forward.

To be honest, I am not really happy with that solution. The user must have a choice whether he wants to allow Grafana to set cookies on his browser. It is absolutely not acceptable to tell the user there is a “need to accept the cookies banner”. Nor is it acceptable to punish him with nagging Grot banners, if he elects to not accept cookies.

The way Grafana forces corporate cookies onto users, who simply want to read the Open Source docs, is IMHO distressing.