Helm setup: 'mimir or loki' alert type not enabled

I have kube prometheus installed in kubernetes, then I set up loki and promtail like this:

helm repo add grafana Grafana Community Kubernetes Helm Charts | helm-charts
helm repo update
helm upgrade --install loki --namespace=monitoring grafana/loki-stack
helm upgrade --install promtail grafana/promtail --set “loki.serviceName=loki” -n monitoring

I can see my logs in grafana. However the ‘mimir or loki alert’ option is disabled. I found some mention about enabling the ruler api and possibly changing the storage type but I’m unsure how to do this. Looking at the helm chart, it wasn’t clear to me which values to modify.

Ideally I would like to use Persistent Storage Volume for storage (if that’s needed) so setup is simpler.

Thanks for the help!