Helm installation with persisistent storage does not bind storage

Hey guys,
I am trying to install Loki with persistent storage via helm.
I followed the steps mentioned in the docs:

  1. Add repo
  2. Update chart repo
  3. Deploy

The deploy command I use was:

helm upgrade --install loki grafana/loki-stack  --set grafana.enabled=true,prometheus.enabled=true,prometheus.alertmanager.persistentVolume.enabled=false,prometheus.server.persistentVolume.enabled=false,loki.persistence.enabled=true,loki.persistence.storageClassName=standard,loki.persistence.size=5Gi

Grafana starts but I cant choose Loki as data-source. The pod ‘loki-0’ does not start and under the events of ‘kubectl describe pod loki-0’ I get:
Type Reason Age From Message
---- ------ ---- ---- -------
Warning FailedScheduling 19s (x2 over 19s) default-scheduler 0/1 nodes are available: 1 pod has unbound immediate PersistentVolumeClaims.

Has anyone else experienced this and can help me, to get this pod running?

Thanks in advance!

Hi @puellf,

I just ran your kubectl command on a DigitalOcean cluster and received the same error.

Let’s try and pin this down, shall we? Where are you deploying to? And what K8s version? LAstly, can you inspect your PVC? Run kubectl get pvc and grab the PVC name and describe it. It should be: kubectl describe pvc storage-loki-0

With this command, my message reads:
storageclass.storage.k8s.io "standard" not found

1 Like

@puellf,

just tested this on minikube and a GKE cluster and the volume successfully mounted in both cases. Everything provisioned succesfully. I’ll be very curious to hear where you are deploying to…

Hey @mattabrams,
first of thank you for replying and looking into it!
Since I first wanted to test my solution before deploying it to a test server. I tried to deploy it on my local k8s cluster. It is hosted by Docker Desktop since I am working on a Windows-machine and do not have have the rights to enable WSL2.
So let’s get into version-details:

  • Win-Ver: 1909
  • Win-Build: 18363.1316
  • Docker-Engine: v20.10.5
  • Kubernetes: v1.19.7
  • Helm: v3.5.3

Running kubectl get pvc does show me that storage-loki-0 exists but is pending.
Describe does print the same error you are describing in your first message:

  Type     Reason              Age                  From                         Message
  ----     ------              ----                 ----                         -------
  Warning  ProvisioningFailed  24h (x71 over 25h)   persistentvolume-controller  storageclass.storage.k8s.io "standard" not found
  Warning  ProvisioningFailed  43s (x8 over 7m43s)  persistentvolume-controller  storageclass.storage.k8s.io "standard" not found

Thanks again for responding!

@puellf,

The command failed for me on Docker Desktop K8s as well. This appears to be a known issue with Docker Desktop. If you are looking to play/develop Kubernetes on your local machine, I’d suggest giving Minikube a try, or seeing if Grafana Cloud suits your needs.

1 Like

@mattabrams Thanks a lot I gonna look into this. You were a great help!

1 Like