Having trouble with enabling Tempo Search in Grafana

Hello. I’m trying to enable the Tempo Search feature in Grafana as described here: Tempo in Grafana | Grafana Tempo documentation

I have added the following to the Grafana helm chart values:

...
grafana.ini:
  feature_toggles:
    enable: tempoSearch tempoBackendSearch
...

And the following to the Tempo helm chart values:

...
search:
  enabled: true
...

This results in the following additions to the configmaps:

...
data:
  tempo.yaml: |
    search_enabled: true
...
...
data:
  grafana.ini: |
    [feature_toggles]
    enable = tempoSearch tempoBackendSearch
...

Additionally the version is v9.0.6. Am I missing something?

Honestly not sure. Can you confirm that Grafana has loaded that ini correctly. We set the Tempo related flags (although I think some of these have been retired):

enable = tempoServiceGraph tempoSearch tempoBackendSearch tempoApmTable traceqlEditor

I fixed it - in my case it was because I was making my change in one cluster and looking at the grafana UI of another cluster. Good old error code 1D10T.

1 Like