Grafana with wmi_exporter?

Banging my head on the monitor here :slight_smile:

Latest Grafana and Prometheus - works great using defaults

Swap Prometheus out for martinlindhe’s wmi_exporter and I can browse to the metrics page fine from browser but Grafana data source says “updated” but no message at the bottom saying it worked.

Has anyone done this and could give me some idea of where to check?

NB. I’ve also tried 3 version of wmi_exporter and a v5 version of Grafana. The only difference was that the v5 of Grafan showed a red warning triangle when saving the data source, although no text with it.

Just for others who may be new to the whole Grafana/Prometheus thing, although it seemed like wmi_exporter produced Prometheus output, it doesn’t - it produces Prometheus input instead. You have to create a new target in Prometheus pointing to the box running wmi_exporter and then point Grafana to the Prometheus service itself, which then exposes the metrics.

Easy when you know the overall concepts but very confusing when you don’t and are struggling to learn - lol!

1 Like