[Grafana v8] Time Series Visualization - Transparent Color & Z Index Override | Table Visualization - Value Mappings

Hi All,

lets get this to the point, this might be a bug (?) in the new version (v8)

[previous version] Graph (old) visualization

  1. transparent color = really transparent
  2. has override option: z index

[current version] Time Series
*version 8

  1. transparent color = BLACK → not transparent
  2. missing override z Index

Table Visualization

  1. value mappings
    I applied value mappings as below, color and text have changed exactly what I want → perfect!
    but, why are the other cells also changed into green where there is NO value mapping for that green color?

    ANSWER
    the green color is because of this option:
    image
    set the base to transparent → fix the issue

thanks,
Boyke Ferdinandes

Yes, the lack of a Z-override is really annoying.
My CPU-graph has “idle” almost at the bottom (instead of at the top), and my RAM-graph has “free” between “used” and “cached”. This makes these graphs look rather weird.

Oh, I also noticed that “Negative value” (or whatever it’s called) is also missing, so my network traffic graph has two series that point up, instead of one pointing down.

I ended up using the query ORDER BY to sort the series into the order I want…

Finally got time to look at this again… I have struggled to find good examples of this… I’m using Prometheus as my data-source, and I’ve seen references to “Use Transformations > Organize fields”, but I can’t make that work (“Organize fields only works with a single frame. Consider applying a join transformation first.”)

The query is netdata_system_ram*1024, and I’m trying to sort the four dimensions it returns in a specific order.