Grafana Templating Graph - Time Interval Issue

Hi Grafana Community,

I have an issue with a templating dashboard with multiple panels which basically shows different time interval for all devices being queried when zooming.

On this particular dashboard I have Windows servers and their data is being collected through Telegraf and being sent to Influxdb. I have the below Telegraf settings for all of them.

  • interval = “1m”
  • round_interval = true

However their time interval is not properly synchronized/visualized in panels, which causes many problems in regards to alerts, counting, etc. I’ve bounced the telegraf service in all servers and still the same. I have the same config on other linux servers and do not have this issue.

These are the details of my environment.

  • Grafana version: 4.4.3
  • Influxdb version: 1.2.0
  • Telegraf version: 1.0.1
  • Grafana and influxdb are installed/running on same server.

Do you have any insights what could be causing this and how to fix it?

Thanks,

Hi,

Could you please provide a screenshot which underlines the problem? I’m not sure if you think this is a problem with Grafana or Influx/Telegraf?

Thanks

Marcus

Hi Marcus,

Thanks for your follow up.

It seems this problem may have been resolved as of now but we will keep on monitoring it.

This screenshot shows how it was before showing values at random seconds while zooming.

45 PM

and this screenshot shows how it is now while zooming.

48 PM

Let me know your thoughts.

Regards,
RC

Submitted too soon.

Forgot to mention that we still have same issue on a graph which purpose is for alerting only. This was setup due to alerts cannot be set using template variables.

07 PM

Hi,

Have you configured your influxdb datasource by setting the min time interval?

If I understand you correctly you write data to influx each minute why you should use a min time interval of 1 min.

A bit unsure since this feels like the same problem you initially had. Why are no labels on series, just Disk Usage? Where you says it works you have labels on series, i.e. AD-CA-2-C

Marcus

1 Like

Thanks for your follow up.

I set the time interval in my influxdb datasource as advised and it seems is working now as expected.
This graph is for alert purposes only that’s why we have disk space only.

I will keep on monitoring for a few days and will confirm if everything still working as it is now.

Thanks,
RC