Grafana SMTP configuration

Hello All,

When I tried to set up an alert in grafana I’m getting an error "
SMTP not configured, check your grafana.ini config file’s [smtp] section". this is through the local host
when I tried through the it is working. Can you please help me to resolve this problem?

Many Thanks

Semicolon at the start of a line in the ini file means it is commented out. So remove the semicolons and it should work.

l am new to grafana. I am using Ubuntu 18.04. Installed 'grafana 8.0.3., mariaDB as database. When I try to access database from pc it is not connecting. Not giving any error of not connecting etc. But going on as ‘Testing…’ status on the grafana browser. I have modified the /etc/grafana/grafana.ini file by editing ‘type’, ‘user’, ‘password’. But when I check the log-file it seems that the editing does not have effect, as though I have changed the ‘type’ from sqlite3 to mysql, it is still showing sqlite3. Now, I found that I need to remove the ‘;’ before the line. But if I do that then grafana can not be started.
$service grafana-server start resulting in ‘fail’.

Any tips would be very helpful to solve these issues.


This topic was automatically closed after 365 days. New replies are no longer allowed.