Grafana-server starting with weird errors

I had trouble starting grafana.

I am running manjaro and installed it via:

$ yay -S grafana

Then i tried running it with:

$ grafana-server

but grafana gave me this error message:

Grafana-server Init Failed: Could not find config defaults, make sure homepath command line parameter is set or working directory is homepath

After looking around the net for a while i found out grafana uses the default location:


so i set the homepath to that and the config path to:


Now grafana does eomthing when i type in grafana-server but it ends in error messages:

/usr/share/grafana c=3 grafana-server
Failed to start grafana. error: failed to initialize file handler: open /var/log/grafana/grafana.log: permission denied

so obvioulsy i tried running it with sudo but i get errors again:

EROR[09-18|22:21:45] can’t read datasource provisioning files from directory logger=provisioning.datasources path=/var/lib/grafana/conf/provisioning/datasources error=“open /var/lib/grafana/conf/provisioning/datasources: no such file or directory”
EROR[09-18|22:21:45] Failed to read plugin provisioning files from directory logger=provisioning.plugins path=/var/lib/grafana/conf/provisioning/plugins error=“open /var/lib/grafana/conf/provisioning/plugins: no such file or directory”
EROR[09-18|22:21:45] Can’t read alert notification provisioning files from directory logger=provisioning.notifiers path=/var/lib/grafana/conf/provisioning/notifiers error=“open /var/lib/grafana/conf/provisioning/notifiers: no such file or directory”
EROR[09-18|22:21:45] can’t read dashboard provisioning files from directory logger=provisioning.dashboard path=/var/lib/grafana/conf/provisioning/dashboards error=“open /var/lib/grafana/conf/provisioning/dashboards: no such file or directory”

However i can visit and see the login. Does that mean i can just ignore the errors?