Grafana server not start (after 8.2.0 upgrade)

Hi there, after the upgrade to the 8.2.0 version , I got this message:

● grafana-server.service - Grafana instance
Loaded: loaded (/usr/lib/systemd/system/grafana-server.service; disabled; ven
Active: failed (Result: start-limit-hit) since ven 2021-10-08 11:04:51 CEST;
Docs: http://docs.grafana.org
Process: 21812 ExecStart=/usr/sbin/grafana-server --config=${CONF_FILE} --pidf
Main PID: 21812 (code=killed, signal=SYS)

ott 08 11:04:51 server systemd[1]: grafana-server.service: Main process exited,
ott 08 11:04:51 server systemd[1]: grafana-server.service: Unit entered failed s
ott 08 11:04:51 server systemd[1]: grafana-server.service: Failed with result 's
ott 08 11:04:51 server systemd[1]: grafana-server.service: Service hold-off time
ott 08 11:04:51 server systemd[1]: Stopped Grafana instance.
ott 08 11:04:51 server systemd[1]: grafana-server.service: Start request repeate
ott 08 11:04:51 server systemd[1]: Failed to start Grafana instance.
ott 08 11:04:51 server systemd[1]: grafana-server.service: Unit entered failed s
ott 08 11:04:51 server systemd[1]: grafana-server.service: Failed with result 's
lines 1-16/16 (END)…skipping…

[ Linux server 4.4.0-210-generic #242-Ubuntu ]
[Description: Ubuntu 16.04.7 LTS xenial]

How could fix it? Thank you very much for your support

1 Like

I am having the same problem. Service will not start following the 8.2.0 upgrade yesterday.

1 Like

Same problem on two Ubuntu 18.04.6 LTS machines.
Couldn’t find any relevant log entrys.

1 Like

I have the same problem on Ubuntu 18.04 .

It seams like it gets killed, when I try to start it with systemd.

audit: type=1326 audit(1633704633.616:24): auid=4294967295 uid=121 gid=132 ses=4294967295 pid=30500 comm=“grafana-server” exe="/usr/sbin/grafana-server" sig=31 arch=c000003e syscall=12 compat=0 ip=0x7f7c414730a9 code=0x0

If I start it manually it will start and work…

To fix this just comment some parameters in the systemd-file.
I think, this is because of the old systemd in the 18.04

cat /usr/lib/systemd/system/grafana-server.service  | grep "#"
#ProcSubset=pid
#ProtectClock=true
#ProtectHostname=true
#ProtectKernelLogs=true
#ProtectProc=invisible
#SystemCallFilter=@system-service

4 Likes

Thanks. Now I’m a step further.

The new error is now that of the image-renderer, from the other topic Image-renderer preventing grafana-server 8.2.0 to start

Thanks, this helped me get up and running again after an apt upgrade.

$ lsb_release -a
Description:    Ubuntu 18.04.6 LTS
$ uname -a
Linux 4.15.0-159-generic #167-Ubuntu SMP Tue Sep 21 08:55:05 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

I have the same problem on Debian 9.13. But my systemd-file has no such parameter.

Thanks a lot. This fix worked for me on my raspberry pi.

Hallo,

I installed grafana fo the first time an I didn´t start with the granafa-server startup.

sudo /bin/systemctl start grafana-server

Manual it works: sudo /usr/sbin/grafana-server --config=/etc/grafana/grafana.ini --homepath=/usr/share/grafana

Please explain me how you fix the startup problem on raspberry pi.

Best regards
Kasper

I can confirm rolling back to 8.1.6 on my Ubuntu 20.04 instance fixed things.

It looks like Systemd: Upgrading from 8.0.6 to 8.2.0 broke grafana · Issue #40162 · grafana/grafana · GitHub is tracking this.

for me the solution from @altuhovd did work. Just open the file /usr/lib/systemd/system/grafana-server.service in an editor and comment all lines with the hash “#” sign as shown in Dimitriy’s post above.
Meanwhile saw the next post from @deviantintegral and could figure out that only the line
#SystemCallFilter=@system-service
has to be commented and grafana service starts without issues.

Hi,

thank the only think it works on my pi was to edit the /usr/lib/systemd/system/grafana-server.service and change the code to:
I hope I have no other problems
Thank you for your fast answer.

[Unit]
Description=Grafana instance
Documentation=http://docs.grafana.org
Wants=network-online.target
After=network-online.target
After=postgresql.service mariadb.service mysql.service

[Service]
EnvironmentFile=/etc/default/grafana-server
User=grafana
Group=grafana
Type=simple
Restart=on-failure
WorkingDirectory=/usr/share/grafana
RuntimeDirectory=grafana
RuntimeDirectoryMode=0750
ExecStart=/usr/sbin/grafana-server                                                  \
                            --config=${CONF_FILE}                                   \
                            --pidfile=${PID_FILE_DIR}/grafana-server.pid            \
                            --packaging=deb                                         \
                            cfg:default.paths.logs=${LOG_DIR}                       \
                            cfg:default.paths.data=${DATA_DIR}                      \
                            cfg:default.paths.plugins=${PLUGINS_DIR}                \
                            cfg:default.paths.provisioning=${PROVISIONING_CFG_DIR}  


LimitNOFILE=10000
TimeoutStopSec=20
UMask=0027

[Install]
WantedBy=multi-user.target

Hello @altuhovd , thank you very much for your help. This solution worked for me